home / blog

xmltv manip timezone fail [solved]

Fail

When trying to use xmltv with mythtv, specifically tv_grab_uk_rt, with Ubuntu 10.4 the following error is seen.

XMLTV requires a Date::Manip timezone of +0000 to work properly.
Current Date::Manip timezone is 1. 

Fix

Use the latest version and dependencies from debian. This is prob. simplest, although same result can be achieved with messing with sources list and dummy packages etc. Just cut and past the following:

wget http://ftp.debian.org/debian/pool/main/libp/libparse-recdescent-perl/libparse-recdescent-perl_1.965001+dfsg-1_all.deb
wget http://ftp.debian.org/debian/pool/main/x/xmltv/libxmltv-perl_0.5.57-3_all.deb
wget http://ftp.debian.org/debian/pool/main/x/xmltv/xmltv-gui_0.5.57-3_all.deb
wget http://ftp.debian.org/debian/pool/main/x/xmltv/xmltv-util_0.5.57-3_all.deb
wget http://ftp.debian.org/debian/pool/main/x/xmltv/xmltv_0.5.57-3_all.deb

sudo dpkg -i libparse-recdescent-perl_1.965001+dfsg-1_all.deb
sudo dpkg -i libxmltv-perl_0.5.57-3_all.deb 
sudo dpkg -i xmltv-util_0.5.57-3_all.deb 
sudo dpkg -i xmltv-gui_0.5.57-3_all.deb 
sudo dpkg -i xmltv_0.5.57-3_all.deb 

References

https://bugs.launchpad.net/ubuntu/+source/xmltv/+bug/544522

This entry was posted in geek and tagged , , . Bookmark the permalink.

Comments are closed.